Mysql-server update on Lenny to Squeeze Debian

Posted on Updated on

By accidentally stubbling over my version of the Mysql-server on a wiki page and comparing that with the CogPO wiki version I found that I was on 5.0 while the newer Debian Squeeze was 5.1.

mysql-server-5.0 is a virtual package in Debian Squeeze relying on mysql-server-5.1 while I seemed to have 5.0.51a-24+lenny5. The distribution upgrade from Lenny to Debian apparently didn’t upgrade the Mysql-server!? So was I off the security updates and with several vulnerabilities in the first part of the year?

One page on the Internet by Wolfgang Karall suggested installing the mysql-server package and purging the mysql-server-5.0 package, and I tried the following.

$ aptitude install mysql-server

$ aptitude purge mysql-server-5.0

$ /etc/init.d/mysql start

And yet my wiki runs.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s